Re: [NTG-context] German ß

Mojca Miklavec mojca.miklavec.lists at gmail.com
Sun Oct 16 23:45:51 CEST 2005


Wolfgang Zillig <wolfgang.zillig at student.kuleuven.be> wrote:
> Hello,
>
> i have some problems with an selfcreated typescriptfile. Until one of
> the last context-updates everythin works fine. The font I use is from
> the hfbright package (the hfbright package is a free version of the
> cmbright font) but when I created that typescript I did't relalize that
> a full font package was available and I renamed the fonts (therefore I
> will not provide that ugly typescript file here). I don't know what has
> changed but the german ß is not working any more. I use as font encoding
> ec and as regime win.
>
> I'm a bit confused where exactly my problem lies: either the encoding is
> wrong, but I do't know which one is right because in the latex package
> hfbright the encoding is called OT1. Has anyone an idea how to fix this
> problem or can anyone help me to set up a context module like the
> hfbright-module?
>
> Many thanks
>
> Wolfgang

Out of curiosity: what happens if you add the following line somewhere
after the definition of encoding and after font switching?

    \definecharacter ssharp 25

Also try to test a word like "bi\ssharp chen" (this should prevent
problems with input regime).

If this works, it's necessary to add support for OT1 (if this is not
already default), see
http://source.contextgarden.net/enco-ec.tex for example.

Ec is not supposed to work properly (in LaTeX it's known under the
name T1), texnansi also has other character positions, but ssharp
could work there.

Mojca


More information about the ntg-context mailing list