[NTG-context] puzzling metafun graphics

Thomas A. Schmitz thomas.schmitz at uni-bonn.de
Mon Sep 12 18:29:13 CEST 2005


OK, I'm answering my own post. The plot thickens. It looks like this  
has something to do with file names. It only happens when I have a  
name with a period in it. Thusly, file 05.11.08.tex will not run MP  
to PDF, when I copy the exact same file to 05_11_08.tex, everything  
works as it should.

This may have something to do with the fact (as I just found out)  
that newtexexec doesn't even want to touch these files. I have two  
identical files in a directory, one called 05.10.18.tex, the other  
05_10_18.tex. Here's what happens when I run newtexexec on them:

TeXExec | processing document '05.10.18.tex'
TeXExec | runtime: 0.006379

(and that's it. No output, no action)

TeXExec | processing document '05_10_18.tex'
TeXExec | tex processing method: context
TeXExec | TeX run 1
TeXExec | tex engine: pdfetex
TeXExec | tex format: cont-en
TeXExec | progname: context
This is pdfeTeX, Version 3.141592-1.30.3-2.2 (Web2C 7.5.5)
\write18 enabled.
entering extended mode
(./05_10_18.tex

ConTeXt  ver: 2005.09.08  fmt: 2005.9.9  int: english  mes: english

[snip]

and so on.

Bug or feature? You decide, Hans!

Best

Thomas

On Sep 12, 2005, at 5:45 PM, Thomas A. Schmitz wrote:

> This one hast just cost me two hours, and I'm still baffled. The  
> story (in shorthand):  was trying to integrate a positional metafun  
> graphic into a presentation. I got no output. I tried making a  
> minimal example file to reproduce the problem, and sure enough,  
> everything went fine. I rebuilt the entire file, by pasting one  
> paragraph of the original file at a time, and I got exactly the  
> output I wanted. [Drumroll] I deleted the original file and  
> everything associated with it [i.e. all those .tui and .tuo etc.],  
> saved the new file from my /tmp directory to my working directory,  
> and -- I got no output again. diff shows that both files are  
> identical. Looking at the logs, there's only one difference I can  
> spot:
>
> < \openout5 = `test-mpgraph.mp'.
> ---
> > \openout5 = `05.11.08-mpgraph.mp'.
> 205,206c206,207
> <  [MP to PDF] (./test-mpgraph.1) [MP to PDF] (./test-mpgraph.2)
> < [MP to PDF] (./test-mpgraph.3)
> ---
> >  [MP 05.11.08-mpgraph.1] [MP 05.11.08-mpgraph.2]
> > [MP 05.11.08-mpgraph.3]
> 211c212
> < systems         : end file test at line 426
> ---
> > systems         : end file 05.11.08 at line 426
> 213c214
> < [flush and process test-mpgraph.mp afterwards] )
> ---
> > [flush and process 05.11.08-mpgraph.mp afterwards] )
>
> The "MP to PDF" part is missing from the file 05.11.08, which might  
> explain why I don't see anything in the resulting pdf. But why? Can  
> anybody enlighten me why the same file can behave differently? And  
> how I can coax ConTeXt into running this MP to PDF thingy? Thanks
>
> Thomas
> _______________________________________________
> ntg-context mailing list
> ntg-context at ntg.nl
> http://www.ntg.nl/mailman/listinfo/ntg-context
>



More information about the ntg-context mailing list