[NTG-context] TEXMFMAIN problem in gwTeX (font installation)

Ville Voipio ville.voipio at kpatents.com
Fri Apr 29 15:03:34 CEST 2005

I have spent some very interesting time trying to install the TeXlive 
fonts by using texfont type-tmf.dat. What happened was that a lot of 
complaints about "unknown subpath ../afm/public/urw" were given even 
though the path should have been there. This is a known problem, has 
been on several mailing lists, as well.

After a lot of thinking it became clear that texfont was really unable 
to find any font files. By browsing through the texfont.pl, the reason 
became evident: In gwTeX the root variables are:

    TEXMFMAIN = /usr/local/teTeX/share/texmf
    TEXMFTE = /usr/local/teTeX/share/texmf.tetex

The problem here is that all the TeXlive fonts (and almost everthing 
else) is really in the TEXMFTE tree.

My quick'n'dirty was to make new file type-tmf-gwtex.dat by replacing 
all occurrences of TEXMFMAIN by TEXMFTE. Running that one in batch mode 
works fine.

Problem solved -- this time. But the solution is not a beautiful one. 
Could someone suggest something cleaner? Or has this been solved already 
(I tried googling after the answer without success)?

- Ville

More information about the ntg-context mailing list