[NTG-context] \type{a_b} inside \bTABLE ... \eTABLE

Mojca Miklavec mojca.miklavec.lists at gmail.com
Mon Apr 11 23:39:17 CEST 2005


Hello,

there's a very comical behavior of \type{sometextfollowedby_underscore} 
inside \bTABLE and \eTABLE. For example:

\starttext
\bTABLE
     \bTR\bTD \type{a_b} \eTD\eTR
\eTABLE
\stoptext

\type{_} or \type{_b} work OK, \type{a_b} outside the table works OK as 
well.

---

I tried to find \def\type in ConTeXt source, but I couldn't and I'm also 
not advanced enough to interpret the error message below. Any ideas?

(I would use the shorter form, \_, but the results are not quite the 
same. I solved my problem temporary by using \type{a}\type{_b} with 
quite some (unnecessary ?) "\type"-ing, but I'm still curious about the 
reason for the strange behavior.)

Thank you,
	Mojca


! Missing $ inserted.
<inserted text>
                 $
<to be read again>
                    _
<argument> \type {a_
                     b}
\handleTBLcell ...{\bTBLCELL \TBLcharalign {#2}{#4
                                                   }\eTBLCELL \inTBLcell 
{#1}...
<inserted text> ...bl \begintblrow \makeTBL {1}{1}
                                                   \nexttblcol 
\endtblrow \en...

\endTBL ...x {\trialtypesettingtrue \the \tbltoks
                                                   }\ifautoTBLspread 
\checktb...
...
l.4 \eTABLE

?
! Emergency stop.
<inserted text>
                 $
<to be read again>
                    _
<argument> \type {a_
                     b}
\handleTBLcell ...{\bTBLCELL \TBLcharalign {#2}{#4
                                                   }\eTBLCELL \inTBLcell 
{#1}...
<inserted text> ...bl \begintblrow \makeTBL {1}{1}
                                                   \nexttblcol 
\endtblrow \en...

\endTBL ...x {\trialtypesettingtrue \the \tbltoks
                                                   }\ifautoTBLspread 
\checktb...
...
l.4 \eTABLE


More information about the ntg-context mailing list