[NTG-context] xecontext/bibtex issue ?

Mark Smith mark at bbprojects.net
Fri Mar 11 15:53:05 CET 2005


Adam Lindsay wrote:

>Mark Smith said this at Fri, 11 Mar 2005 14:56:06 +0100:
>
>>The problem is that bibtex "can't read" the .aux file that is generated
>>by xextex.
>
>Okay, can we see a copy (or reduction) of that file, then?


Hmm... Interesting. In preparing a short and highly sanitized file *with* citations, I find that the problem no longer exists. Jumped the gun with the assumption about bibtex.

I have three files. They all started out as LaTeX articles. Each could be processed w/o problems:

        latex
        bibtex
        latex
        latex
        
I then made the necessary modifications to generate a ConTeXt version of each file and:

        context
        bibtex
        context
        
also ran w/o problems.
        
However, with the minimum necessary modifications to the preamble:

        "xecontext"
        
...would stop after generating the xdv and bibtex would not read the .aux.

I found that removing all of the paragraphs and elements containing citations enabled all three files to be processed to pdf via xetex.
        
Now, having made a sanitized and very short version of one of the three files, but leaving a small number of citations in place, I find that:

        xecontext
        bibtex
        xecontext
        
...runs fine as expected.

I've got my work cut out to find the problem. Any tips about what I might look for ?

Could it be associated with particular environments or characters ?

wt[and apologies]ia,

mark.


More information about the ntg-context mailing list