<div dir="ltr"><br><div class="gmail_extra"><br><div class="gmail_quote">On Thu, Jun 18, 2015 at 9:14 PM, Graham Douglas <span dir="ltr"><<a href="mailto:graham.douglas@readytext.co.uk" target="_blank">graham.douglas@readytext.co.uk</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex">Dear All<br>
<br>
Apologies for recent noise over my inability to build LuaTeX 0.80 on<br>
Windows. I finally got LuaTeX 0.80 to build<br>
but had to  re-install MinGW/MSYS:<br>
<br>
MinGW from here:<br>
<a href="http://mingw-w64.yaxm.org/doku.php/download/win-builds" rel="noreferrer" target="_blank">http://mingw-w64.yaxm.org/doku.php/download/win-builds</a><br>
<br>
MSYS from here:<br>
<a href="http://sourceforge.net/projects/mingw-w64/files/External%20binary%20packages%20%28Win64%20hosted%29/MSYS%20%2832-bit%29/" rel="noreferrer" target="_blank">http://sourceforge.net/projects/mingw-w64/files/External%20binary%20packages%20%28Win64%20hosted%29/MSYS%20%2832-bit%29/</a><br>
--- downloaded (MSYS-20111123.zip<br>
<br>
After that, a fresh SVN checkout as well and it worked. Build scripts no<br>
longer seems to run makeinfo<br>
but I have no idea why this suddenly works.  I just accept that it did.<br>
<br>
Warm wishes<br>
<span class=""><font color="#888888">Graham<br>
</font></span></blockquote></div><div class="gmail_extra"><br></div>good.</div><div class="gmail_extra">I usually run<br>$>./build.sh --parallel --jit  --mingw64  &> out-mingw64<br clear="all"><div><br></div><div>and then </div><div>$> tail out-mingw64 <br></div><div><br></div><div><br></div><div><div>  CC       libluatex_a-avlstuff.o</div><div>  CC       libluatex_a-managed-sa.o</div><div>  CC       libluatex_a-utils.o</div><div>  CC       libluatex_a-unistring.o</div><div>  AR       libluatex.a</div><div>  CC       luatexdir/luatex-luatex.o</div><div>  CC       mplibdir/luatex-lmplib.o</div><div>  CXXLD    luatex.exe</div><div>-rwxrwxr-x 1 luigisvn luigisvn 11209728 Jun 14 14:57 build-windows64/texk/web2c/luajittex.exe</div><div>-rwxrwxr-x 1 luigisvn luigisvn 10830336 Jun 14 14:57 build-windows64/texk/web2c/luatex.exe</div></div><div><br></div><div>Anyway, you should always check out-mingw64 for strange warnings/errors.</div><div><br></div><div>Can you also check if luajittex build is ok?</div><div><br></div><div>--parallel means (look into build.sh)</div><div><div>JOBS_IF_PARALLEL=${JOBS_IF_PARALLEL:-3}</div><div>MAX_LOAD_IF_PARALLEL=${MAX_LOAD_IF_PARALLEL:-2}</div></div><div><br></div><div>but on my quad-core with hyperthreading I set</div><div><div><div>JOBS_IF_PARALLEL=${JOBS_IF_PARALLEL:-16}</div><div>MAX_LOAD_IF_PARALLEL=${MAX_LOAD_IF_PARALLEL:-16}</div></div></div><div><br></div><div>(and yes, it can freeze my box ).</div><div><br></div><div><br></div><div><br></div><div><br></div><div><br></div>-- <br><div class="gmail_signature">luigi<br></div>
</div></div>