[Dev-luatex] warning when trying to include pdf 2.0

Ulrike Fischer news3 at nililand.de
Mon May 25 08:51:47 CEST 2020


When I try to include a pdf 2.0 image in a pdf set to 2.0 I get a
warning:

PDF inclusion: found PDF version 
'2.0', but at most version '2.0'
allowed


Example:

\pdfvariable compresslevel=0
\pdfvariable majorversion=2
\pdfvariable minorversion=0

\saveimageresource {version20.pdf}

abc
\bye

The warning disappears when I set \pdfvariable minorversion=2, so it
looks as if the code would set the minor version of the included pdf
to 2 instead of 0. 


-- 
Ulrike Fischer 
http://www.troubleshooting-tex.de/



More information about the dev-luatex mailing list