[Dev-luatex] invalid list tail

Benjamin Desef projekter-git at yahoo.de
Wed Sep 14 16:49:46 CEST 2016


Hi,
I just came up with an error using microtype and the fourier font package. Robert Schlicht (maintainer of microtype) adviced me to send the bug report here, since he cannot not reproduce the bug in LuaTeX 0.95; my version is 0.98.4 from MikTeX NEXT.MWE:
\documentclass{article} \usepackage{fourier, microtype} \begin{document}   particle $\infty$\end{document}

This willcompile fine with pdfLaTeX and apparently older LuaLaTeX versions, but the most recent will give the error (complete log isattached) ! error:  (linebreak): invalid list tail,probably missing glue!  ==> Fatal error occurred, no output PDFfile produced! The errorseems to critically depend on the word before the math symbol – if I change itto “Test”, everything works. I also tried inverting the order of loading.In mydocuments, I use Fourier only for text mode; if instead of loading the package,I just say \renewcommand{\rmdefault}{futs}, the error still persists. And even if I turn out everything [activate=false], it still is there.
Benjamin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.ntg.nl/pipermail/dev-luatex/attachments/20160914/0b7aaa41/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: texstudio_GD4676.log
Type: application/octet-stream
Size: 20892 bytes
Desc: not available
URL: <http://mailman.ntg.nl/pipermail/dev-luatex/attachments/20160914/0b7aaa41/attachment-0001.obj>


More information about the dev-luatex mailing list