[Dev-luatex] Release 0.8 build failed on Windows

Graham Douglas graham.douglas at readytext.co.uk
Sun Jun 14 15:55:33 CEST 2015


Hi All

Platform: Windows 7 Ultra (64-bit) using MinGW32

I just checked out the code for version 0.8 and tried to build LuaTeX on
Windows but
it failed. The final error message is as follows (some other errors are
listed below).
Hoping that the details below are helpful to track the issues.

Warm wishes
Graham

=========
Final error
=========
make[2]: Leaving directory `/e/luatex/0.80/build/texk/kpathsea/win32'
make[1]: Leaving directory `/e/luatex/0.80/build/texk/kpathsea'
./build.sh: line 272: cd: texk/web2c: No such file or directory
make: *** No rule to make target `luatex.exe'.  Stop.
E:\MinGW\bin\strip.exe: 'build/texk/web2c/luatex.exe': No such file
ls: build/texk/web2c/luatex.exe: No such file or directory

Earlier errors
==========
Earlier in the build I saw a few more errors but I don't know if these are
related, just thought I would note them here



make[1]: Entering directory `/e/luatex/0.80/build/doc'
  MAKEINFO ../../source/doc/tlbuild.info
makeinfo: unrecognized option `--set'
Try `makeinfo --help' for more information.
make[1]: *** [../../source/doc/tlbuild.info] Error 1
make[1]: Leaving directory `/e/luatex/0.80/build/doc'
make: *** [all-recursive] Error 1

==========
Error
=================================
./build.sh: line 261: cd: libs/zzip: No such file or directory
Making all in .
make[1]: Entering directory `/e/luatex/0.80/build'
make[1]: Leaving directory `/e/luatex/0.80/build'
Making all in doc
make[1]: Entering directory `/e/luatex/0.80/build/doc'
  MAKEINFO ../../source/doc/tlbuild.info
makeinfo: unrecognized option `--set'
Try `makeinfo --help' for more information.
make[1]: *** [../../source/doc/tlbuild.info] Error 1
make[1]: Leaving directory `/e/luatex/0.80/build/doc'
make: *** [all-recursive] Error 1
make  all-recursive
make[1]: Entering directory `/e/luatex/0.80/build/libs/zlib'
Making all in .
make[2]: Entering directory `/e/luatex/0.80/build/libs/zlib'

========================
Error
===========================
make  CONF_SUBDIRS=web2c subtexk
make[1]: Entering directory `/e/luatex/0.80/build/texk'
make[1]: *** No rule to make target `subtexk'.  Stop.
make[1]: Leaving directory `/e/luatex/0.80/build/texk'
make: *** [web2c/Makefile] Error 2
echo a | grep -v b >/dev/null || { echo "*** grep broken, goodbye.";
exit 1; }














More information about the dev-luatex mailing list