[Dev-luatex] Luatex 0.75.0 announcement

Taco Hoekwater taco at elvenkind.com
Mon Mar 4 09:54:10 CET 2013


On Mar 4, 2013, at 9:49 AM, Norbert Preining <preining at logic.at> wrote:

> Hi Taco,
> 
> On Fr, 01 Mär 2013, Taco Hoekwater wrote:
>> I have just uploaded the archives for a new luatex release, 0.75.0.
> 
> Seems that since 0.74.0 something has changed that broke compilation
> on my machine for Debian packages:
> 
> ../../../source/texk/web2c/luatexdir/lua/lepdflib.cc: In function 'int m_EmbFile_save(lua_State*)':
> ../../../source/texk/web2c/luatexdir/lua/lepdflib.cc:912:31: error: 'class EmbFile' has no member named 'save'
> 
> 
> Can you guess the reason for that? 0.74.0 was still compiling fine here.


> poppler is here of 0.18.4
> 

Yes, that is caused by an extension to the 'epdf' library. It works fine with poppler 0.21.0 (the one distributed with the source tree). Hartmut may be able to rewrite the new code so that it works with old poppler, but I am not sure whether he is willing ;)

Best wishes,
Taco
PS The -Wwrite-strings is a fairly standard warning, and not related to the problem at hand.



More information about the dev-luatex mailing list