[Dev-luatex] Luatools from TL '11 pretest don't work

Taco Hoekwater taco at elvenkind.com
Tue Jun 14 08:30:08 CEST 2011


On 06/14/2011 08:15 AM, Li Yanrui (李延瑞) wrote:
> 2011/6/14 Peter Dyballa<Peter_Dyballa at freenet.de>:
>> Hello!
>>
>> When I try to create the fonts base for LuaTeX from TL '11 pretest, as
>> updated yesterday, I don't see any success:
>>
>>         pete 249 /\ luatools --generate
>>
>>         mtxrun          | unknown script 'base.lua' or 'mtx-base.lua'
>>         Exit 1
>>
>> There is also no help available when I invoke luatools with --help or -help
>> or -h or -?.

1. luatools is a context command. Nothing you do with command that will
make lualatex work, for that you need 'mkluatexfontdb' (iirc).

2. If you installed context, the 2011 pretest installer should have run
mtxrun --generate automatically, and that would have prevented the above
'unknown script' message from every happening. Since it did not, can
you please explain what you installed *exactly* so I can try to reproduce?

> The same problem happens in context minimals. you can try to  excute

No, it is quite definitely not the *same* problem, but for you as well:
please run
   mtxrun --generate
by hand, and that should fix the problem.

Best wishes,
Taco


More information about the dev-luatex mailing list