[Dev-luatex] [Fwd: [luatex 0000481]: can't load chinese otf font correctly, always give "LuaTeX warning: lua-loaded font has no characters"]

luoyi luoyi.ly at gmail.com
Thu Sep 16 05:10:31 CEST 2010


sorry, still can't get it to work.

[luoyi at myhost ~/tex]$ mtxrun --script fonts --list --all --pattern=adobe
|grep -i song
adobesongstd             adobesongstdlight
/usr/share/fonts/adobe/AdobeSongStd-Light.otf
adobesongstdlight        adobesongstdlight
/usr/share/fonts/adobe/AdobeSongStd-Light.otf
adobesongstdregular      adobesongstdlight
/usr/share/fonts/adobe/AdobeSongStd-Light.otf
[luoyi at myhost ~/tex]$ which luatex
/usr/local/texlive/2010/bin/x86_64-linux/luatex
[luoyi at myhost ~/tex]$ luatex lf.tex
This is LuaTeX, Version beta-0.63.0-2010090921
 restricted \write18 enabled.
(./lf.tex
! Font \asong=AdobeSongStd-Light at 10pt not loadable: metric data not found
or
 bad.
<to be read again>
                   \asong
l.3 \asong

?
! Emergency stop.
<to be read again>
                   \asong
l.3 \asong

!  ==> Fatal error occurred, no output PDF file produced!
Transcript written on lf.log.
[luoyi at myhost ~/tex]$ head lf.tex
% \input {luaotfload.sty}
\font\asong={AdobeSongStd-Light} at 10pt
\asong
women
\font\couri={CourierStd} at 10pt
\couri
women
\bye



2010/9/16 Li Yanrui (李延瑞) <liyanrui.m2 at gmail.com>

> 2010/9/14 taco <taco at elvenkind.com>:
> > Hi,
> >
> > See forward. Can somebody try this with current versions
> > and possibly report back to the reporter? I am at the
> > ConTeXt meeting which makes working at bugs sort of
> > problematic  and besides, I do not really understand
> > luaotfload all that well.
> >
> > Thanks in advance,
> > Taco
> >
> >
> > The following issue has been SUBMITTED.
> > ======================================================================
> > http://tracker.luatex.org/view.php?id=481
> > ======================================================================
> > Reported By:                luoyi
> > Assigned To:
> > ======================================================================
> > Project:                    luatex
> > Issue ID:                   481
> > Category:                   luatex bug
> > Reproducibility:            always
> > Severity:                   major
> > Priority:                   high
> > Status:                     new
> > ======================================================================
> > Date Submitted:             2010-09-14 10:52 CEST
> > Last Modified:              2010-09-14 10:52 CEST
> > ======================================================================
> > Summary:                    can't load chinese otf font correctly, always
> > give
> > "LuaTeX warning: lua-loaded font has no characters"
> > Description:
> > I'm using TL2010 with the latest luatex , and it looks like luatex can't
> > load
> > chinese otf font correctly. It always give error msg like" LuaTeX
> warning:
> > lua-loaded font has no characters". hope we can solve it.
> >
> > the tex file is:
> >
> > \input {luaotfload.sty}
> > \font\asong={AdobeSongStd-Light} at 10pt
> > \asong
> > women
> > \bye
> >
>
> Now the LuaTeX/plain TeX can works with the latest beta. Because I
> have not the LaTeX enviroment, I just tested this example:
>
> \font\asong={AdobeSongStd-Light} at 10pt
> \asong
> 测试
> \bye
>
> It can work. LuaTeX can find AdobeSongStd-Light.otf rightly and load it.
>
> --
> Best regards,
>
> Li Yanrui (李延瑞)
> _______________________________________________
> dev-luatex mailing list
> dev-luatex at ntg.nl
> http://www.ntg.nl/mailman/listinfo/dev-luatex
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.ntg.nl/pipermail/dev-luatex/attachments/20100916/7dff733a/attachment-0001.html>


More information about the dev-luatex mailing list