[Dev-luatex] luatex 0.51.0 and libpoppler 0.12.* compile error

Martin Schröder martin at oneiros.de
Sun Mar 14 14:09:35 CET 2010


2010/3/14 Norbert Preining <preining at logic.at>:
> On So, 14 Mär 2010, Martin Schröder wrote:
>> Hartmut forked our version of xpdf in r3304.
>
> Ouch. That will make at least the distributors unhappy.
>
>>  1. create a layer between xpdf/poppler and luatex like in pdftex 1.50
>
> Probably hard according to Hartmuts remarks on "no idea how to make that
> consistent with poppler".

I doubt it. At the end you have to adapt only two files for poppler.
http://preview.tinyurl.com/yk9uqm7
http://preview.tinyurl.com/yghn92f

>>  2. push changes like these upstream (i.e. to poppler) so that they
>>     get integrated there
>
> Hahaha, Martin, wasn't it you complaining about them at one of the
> BachoTeXs?

It's unlikely, but remains possible. :-)

Taco?

Best
   Martin


More information about the dev-luatex mailing list