[Dev-luatex] Problems with luatextra, luaotfload etc

Graham Douglas graham.douglas at readytext.co.uk
Sat Jun 12 14:35:56 CEST 2010


Dear All

I hope this question is OK to ask on this list.

Quick  background: I routinely compile LuaTeX on Windows
Vista and use my own runtime environment (via texmf.cnf + environment 
variables etc ) which is not based on a standard TDS --- purely a test
environment. Basically it works OK.

My LuaTeX version is beta-0.60.1-2010060119

I'm interested to explore luatextra, luaotfload etc but
am running into a problem I can't resolve.

I have, this morning, downloaded and installed all the very latest 
versions of luainputenc, lualibs, luaotfload, luatexbase and luatextra


Firstly, here is the minimal test file (say luafonts.tex):

\documentclass{article}
\usepackage{luatextra}
\begin{document}
Hello
\end{document}

When I run this:

$ luatex --fmt=pdflatex $TEXMF/luafonts.tex

I get the following error:

-----------------------------------------------
! LuaTeX error <\directlua >:1: Expected an array of names as second 
argument
stack traceback:
         [C]: in function 'enableprimitives'
         <\directlua >:1: in main chunk.
\luatexbase at ensure@primitive ...s('luatex', '#1')}
                                                   \fi
l.82 \luatexbase at ensure@primitive{luaescapestring}

?
---------------------------------------------------

The full run is below: does anyone know what I'm doing wrong?

I appreciate that my runtime environment is not standard
but to date that's not been an issue.

Thanks to all in advance for any help --- and of course
thanks to the team who write luatextra, luaotfload etc.

Warm regards

Graham
============



This is LuaTeX, Version beta-0.60.1-2010060119
(g:/msys/1.0/trunk/build/texk/luafonts.tex
LaTeX2e <2009/09/24>
(g:/msys/1.0/trunk/build/texk/formats/pdflatex/base/article.cls
Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
(g:/msys/1.0/trunk/build/texk/formats/pdflatex/base/size10.clo))
(g:/msys/1.0/trunk/build/texk/formats/pdflatex/luatextra/luatextra.sty
(g:/msys/1.0/trunk/build/texk/formats/pdflatex/ifluatex.sty)
(g:/msys/1.0/trunk/build/texk/formats/pdflatex/luatexbase/luatexbase-modutils.s
ty
(g:/msys/1.0/trunk/build/texk/formats/pdflatex/luatexbase/luatexbase-loader.sty

(g:/msys/1.0/trunk/build/texk/formats/pdflatex/luatexbase/luatexbase-compat.sty
)
(g:/msys/1.0/trunk/build/texk/formats/pdflatex/luatexbase/luatexbase.loader.lua
))
(g:/msys/1.0/trunk/build/texk/formats/pdflatex/luatexbase/modutils.lua)
! LuaTeX error <\directlua >:1: Expected an array of names as second 
argument
stack traceback:
         [C]: in function 'enableprimitives'
         <\directlua >:1: in main chunk.
\luatexbase at ensure@primitive ...s('luatex', '#1')}
                                                   \fi
l.82 \luatexbase at ensure@primitive{luaescapestring}

?



More information about the dev-luatex mailing list