[Dev-luatex] XML abilities in LuaTeX

TeXWorld texworld at laposte.net
Wed Nov 18 19:30:57 CET 2009


Hans Hagen a écrit :
>
> TeXWorld wrote:
>
>> What about continuing this discussion on dynamic loading lua libraries ?
>
> in the current luatex beta you can load a library with 'require'
>
ok. Currently only libraries written in pure lua work with 'require'.
> we will not provide nor support libraries ourselves as the luatex 
> engine has to be small, maintainable etc etc so it's up to yourself to 
> make sure that your library matches the lua version used in luatex
>
yes of course.
> also, future releases will have some restrictions similar to running 
> commands using write 18 so it's quite likely that for tex live 2010 
> there will be some guards for loading libraries (unless explicitly 
> permitted)
>
> Hans
>
> -----------------------------------------------------------------
>                                           Hans Hagen | PRAGMA ADE
>               Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
>      tel: 038 477 53 69 | fax: 038 477 53 74 | www.pragma-ade.com
>                                              | www.pragma-pod.nl
> -----------------------------------------------------------------
>
>





More information about the dev-luatex mailing list