[Dev-luatex] Did somebody compile luaexpat into LuaTeX yet?

Taco Hoekwater taco at elvenkind.com
Thu Mar 5 12:40:04 CET 2009



David Kastrup wrote:
> 
> Ok, crossed my fingers and got the stuff to compile finally.  I can send
> the diff.  Does anybody have a quick clue what might cause the following
> on startup:
> 
> PANIC: unprotected error in call to Lua API (attempt to index a function value)

You probably have an error in the setup for opening luaexpat in
luastuff.c. Some lua modules define a luaopen_XXX function that can
be called directly, others need a lua_pushcfunction and lua_call,
this has to do with require() vs. dofile().

Best wishes,

Taco



More information about the dev-luatex mailing list