[Dev-luatex] LuaTeX build error on sparc64/amd64 within TeX Live

Taco Hoekwater taco at elvenkind.com
Tue Sep 30 14:56:30 CEST 2008



Edd Barrett wrote:
> Hello,
> 
> I am making TeX Live packages for OpenBSD and have hit problems with
> 64 bit architectures:

Can you try the patch below please?

> OpenBSD does not use ucontext.h, but interestingly this error does not
> show on i386.

Likely because the code autodetects i386 and switches to assembler
code,

> For now I have disabled luatex in the build, due to luatex being in an
> experimental stage, but I thought it would be good to report this and
> get on top of it early rather than later.

yes, thanks for that.

> Also I was wondering if it will be possible to build luatex with an
> external lua  

no. luatex needs a patched lua.

Best wishes,
Taco


Index: src/libs/lua51/Makefile
===================================================================
--- src/libs/lua51/Makefile     (revision 1519)
+++ src/libs/lua51/Makefile     (working copy)
@@ -20,9 +20,9 @@

  # ++ Coco =========
  # Default: autodetect gccasm/setjmp/ucontext/fibers context switch method.
-COCOCFLAGS=
+#COCOCFLAGS=
  # Force use of setjmp (instead of gccasm).
-#COCOCFLAGS= -DCOCO_USE_SETJMP
+COCOCFLAGS= -DCOCO_USE_SETJMP
  # Force use of ucontext (instead of gccasm or setjmp).
  #COCOCFLAGS= -DCOCO_USE_UCONTEXT
  # Uncomment this if you want to disable support for Coco.


More information about the dev-luatex mailing list