[Dev-luatex] How to build luatex on Ubuntu 8.04 desktop?

dhj dhj2006 at gmail.com
Wed Oct 29 12:54:03 CET 2008


I want to build luatex-beta-0.30 on my  Ubuntu 8.04. I run ./build.sh or
./build.sh.linux, it return error.

 ~/luatex-beta-0.30.0$ ./build.sh
Your make is a GNU-make; I will use that
ignore warnings and errors about the main texmf tree
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name...
configure: error: C compiler cannot create executables
See `config.log' for more details.


My gcc version is:

:~/luatex-beta-0.30.0$ gcc -v
Using built-in specs.
Target: i486-linux-gnu
Configured with: ../src/configure -v
--enable-languages=c,c++,fortran,objc,obj-c++,treelang --prefix=/usr
--enable-shared --with-system-zlib --libexecdir=/usr/lib
--without-included-gettext --enable-threads=posix --enable-nls
--with-gxx-include-dir=/usr/include/c++/4.2 --program-suffix=-4.2
--enable-clocale=gnu --enable-libstdcxx-debug --enable-objc-gc --enable-mpfr
--enable-targets=all --enable-checking=release --build=i486-linux-gnu
--host=i486-linux-gnu --target=i486-linux-gnu
Thread model: posix
gcc version 4.2.3 (Ubuntu 4.2.3-2ubuntu7)

Could anyone tell me what's the problem? Thanks!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.ntg.nl/mailman/private/dev-luatex/attachments/20081029/5f5778d2/attachment.html 


More information about the dev-luatex mailing list