[Dev-luatex] [dev-context] new context and luatex packages for Debian

Sanjoy Mahajan sanjoy at MIT.EDU
Sun Nov 30 18:30:22 CET 2008

> Following Taco's release of the new luatex here is now the
> announcement of new packages for context and luatex.

Good news, thanks!

> Both have been uploaded to Debian/experimental
> Version: luatex 0.30.3, context 2008.10.31


The new context passed my usual tests: compiling a couple of 100+-page
books with math and physics equations and figures.  It didn't pass a new
test, mixing Palatino and Euler:

========== start test.tex ===============
\usetypescript[palatino] [ec] 
\definetypeface [palatino] [mm] [math] [euler] [euler] [rscale=1.03] 

c^2 = a^2 + b^2.
========== end test.tex ===============

This test also did not work with my previous context installation (the
2008.05.21 packages).  With either the current or previous packages, the
equation comes out in Euler but as "a^2 b^2 + c^2:" (i.e. missing equals
sign, and the period replaced by a colon).

The test works on live.contextgarden.net (context 2008.11.10), and it
worked with an older set of context minimals a month or so ago.  So I
suspect a problem in my font map files (I'm using lmodern 1.010x-5).
The problem might be caused by something silly that I did; however, as
far as I know I run a vanilla tex setup from your Debian 'unstable'
packages.  Let me know if you have the same problem.


I couldn't find luatex in Debian/experimental.  I tried two methods to
find it.  The first method is:

  $ aptitude update   # with experimental in my sources.list
  $ aptitude install luatex/experimental

It produced:

  Unable to find an archive "experimental" for the package "luatex"

Which was strange, since I also have your line

  deb http://people.debian.org/~preining/TeX/ luatex-sid/

in my sources.list, and it wasn't picked up there either.

For the second method, I visited
which lists these luatex packages

    * experimental (tex): next generation TeX engine
       0.30.3-1: amd64 hppa ia64 kfreebsd-amd64 kfreebsd-i386 sparc

So, there's no i386 package.  I'm using a TP T60, so that's why the
first method didn't find the new luatex.  I've just downloaded the
source package and, as a check, will try to build the binary package.


`Until lions have their historians, tales of the hunt shall always
 glorify the hunters.'  --African Proverb

More information about the dev-luatex mailing list