[Dev-luatex] Problems with texmf.cnf settings

Norbert Preining preining at logic.at
Sat Sep 29 22:12:33 CEST 2007

On Sa, 29 Sep 2007, Norbert Preining wrote:
> There is only ONE BIG PROBLEM:
> $ grep ^TEXMFDIST /usr/share/texmf/web2c/texmf.cnf 
> TEXMFDIST = /usr/share/texmf-{texlive,tetex}

My question is still there, but I temporarly solved it (using two
different names).

Something else: I tried your example:

$ mtxrun --script font --list lmroman10
Error in lua file loading: cannot open : No such file or directory

You said there must be a LUAINPUTS settings, so I did:

$ export LUAINPUTS=/usr/share/texmf/scripts/context/lua//

but with the same effect. 

Desperate as I am I did put the above LUAINPUTS line into the texmf.cnf,
called again the luatools --verbose --generate and then tried the mtxrun
call, again with the same effect.

How are you guys setting up your system??? Is this magic? Or is there
nobody else besides you two actually using/trying it out???

Thanks a lot for any suggestions!

Best wishes


Dr. Norbert Preining <preining at logic.at>        Vienna University of Technology
Debian Developer <preining at debian.org>                         Debian TeX Group
gpg DSA: 0x09C5B094      fp: 14DF 2E6C 0307 BE6D AD76  A9C0 D2BF 4AA3 09C5 B094
To relate an amusing story to someone without remembering that it was
they who told it to you in the first place.
			--- Douglas Adams, The Meaning of Liff

More information about the dev-luatex mailing list