[dev-context] Italic correction missing when using \left...\right

luigi scarso luigi.scarso at gmail.com
Tue Apr 26 10:04:13 CEST 2022


On Tue, Apr 26, 2022 at 8:59 AM Henri Menke <henri at henrimenke.de> wrote:

> On Mon, 2022-04-25 at 22:09 +0200, Henri Menke wrote:
> > Dear devs,
> >
> > When using delimiter with \left...\right the italic correction
> > between
> > the preceding letter and the delimiter is dropped. I've tried this
> > with
> > a few fonts and all show the problem. For Libertinus Math the glyphs
> > even overlap.
> >
> > MWE for mtxrun --script plain (TeX Live 2022)
> >
> >    %\input luaotfload.sty
> >    \font\mathfont="file:LibertinusMath-
> > Regular.otf:mode=base;script=math" at 10pt
> >    \textfont0=\mathfont
> >    \textfont2=\mathfont
> >
> >    \Umathcodenum`f="1D453
> >    \protected\def\langle{\Udelimiter"4"0"27E8\relax}
> >    \protected\def\rangle{\Udelimiter"5"0"27E9\relax}
> >
> >    $f\rangle$
> >
> >    \nulldelimiterspace=0pt
> >    $\left.f\right\rangle$
> >
> >    \bye
>
> Ulrike pointed out \mathitalicsmode=1 on TeX Stack Exchange, but there
> is still an issue with sub_mlists:
>
>    %\input luaotfload.sty
>    \font\mathfont="file:LibertinusMath-Regular.otf:mode=base;script=math"
> at 10pt
>    \textfont0=\mathfont
>    \textfont2=\mathfont
>
>    \Umathcodenum`f="1D453
>    \protected\def\langle{\Udelimiter"4"0"27E8\relax}
>    \protected\def\rangle{\Udelimiter"5"0"27E9\relax}
>
>    \mathitalicsmode=1
>
>    $f\rangle$
>
>    \nulldelimiterspace=0pt
>    $\left.f\right\rangle$
>
>    ${-f}\rangle$
>
>    $\left.{-f}\right\rangle$
>
>    \bye
>

I will check it, but have  you already seen mlist.c  ?

-- 
luigi
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.ntg.nl/pipermail/dev-context/attachments/20220426/54554ce9/attachment.htm>


More information about the dev-context mailing list