[dev-context] \lastxpos and \lastypos should behave like registers

Henri Menke henrimenke at gmail.com
Thu May 23 01:47:54 CEST 2019



On 23/05/19 11:36 AM, Hans Hagen wrote:
> On 5/23/2019 1:11 AM, Henri Menke wrote:
>> Dear devs,
>>
>> The two macros \lastxpos and \lastypos should behave like registers,
>> because that is what they are in LuaTeX.  The following MWE fails with
>>
>> ! You can't use `the character 0' after \the
>>
>> \starttext
>> \the\lastxpos
>> \the\lastypos
>> \stoptext
>>
>> A simple fix would be to wrap the macro in \numexpr like in the attached
>> patch.
> 
> hm, i was actually about to drop them completely ... anyway, i have no 
> problem with the fix but then it also need to be \unexpanded
>   (i'm reshuffling some code so probably no beta for a few days)

Dropping \pdflastxpos and \pdflastypos would break TikZ, so it would be
good if at least the \lastxpos and \lastypos primitives would be
accessible.

Cheers, Henri

> 
> Hans
> 
> -----------------------------------------------------------------
>                                            Hans Hagen | PRAGMA ADE
>                Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
>         tel: 038 477 53 69 | www.pragma-ade.nl | www.pragma-pod.nl
> -----------------------------------------------------------------
> _______________________________________________
> dev-context mailing list
> dev-context at ntg.nl
> https://mailman.ntg.nl/mailman/listinfo/dev-context
> 



More information about the dev-context mailing list