[dev-context] bib: triple dash in article title causes problems (minimal example)

Sanjoy Mahajan sanjoy at MIT.EDU
Mon Nov 23 20:15:39 CET 2009


Taco Hoekwater <taco at elvenkind.com> wrote:

> This is the key problem, I think: adding an explicit \enableregime
> before the \startcomponent will likely fix the problem. The issue
> is that bbl file, which is normally read at \starttext is read at
> a different point in time for source that uses products/projects.

The bibliography was typeset the product file itself, so I put
\enableregime[utf] before the \startproduct.  It worked as you
predicted.  

I had made a related experiment: to put \enableregime[utf] at the start
of the .bbl file, then to run texexec with --once (to prevent bibtex
from remaking the .bbl file).  That also worked, but it was intended as
a method of debuggin rather than as a usable workaround.

However, even with your fix, I'm still partly confused.  Why isn't the
"---" in the article title treated like a TeX em-dash?  In other words,
why is the utf regime needed at all?

-Sanjoy

`Until lions have their historians, tales of the hunt shall always
 glorify the hunters.'  --African Proverb


More information about the dev-context mailing list