[dev-context] Mac installation package

Oliver Buerschaper oliver.buerschaper at mpq.mpg.de
Wed Aug 19 10:43:16 CEST 2009


> I knew I need an installer. :-(
> I have downloaded the archive "t-simplefonts-2009.08.01.zip" from <http://modules.contextgarden.net/simplefonts 
> > and placed this zip file in the place "/usr/local/context/ 
> 2009-06-11-beta/texmf-local" and switched to the terminal:
>
> ---Terminal Output---
> titus:~ jh$ su admin
> Password: ********
> bash-3.2$ cd /usr/local/context/2009-06-11-beta/texmf-local
> bash-3.2$ ls
> t-simplefonts-2009.08.01.zip
> bash-3.2$ sudo unzip t-simplefonts-2009.08.01.zip
> Password: ********
> Archive:  t-simplefonts-2009.08.01.zip
> creating: tex/
> creating: tex/context/
> creating: tex/context/third/
> creating: tex/context/third/simplefonts/
> ...
> bash-3.2$ ls
> doc                          t-simplefonts-2009.08.01.zip
> source                       tex
> bash-3.2$ sudo luatools --generate
> LuaTools | fileio: variable SELFAUTOLOC set to /usr/local/context/ 
> 2009-06-11-beta/texmf-osx-intel/bin
> LuaTools | fileio: variable SELFAUTODIR set to /usr/local/context/ 
> 2009-06-11-beta/texmf-osx-intel
> LuaTools | fileio: variable SELFAUTOPARENT set to /usr/local/context/ 
> 2009-06-11-beta
> LuaTools | fileio: variable TEXMFCNF set to {$SELFAUTODIR, 
> $SELFAUTOPARENT}{,{/share,}/texmf{-local,.local,}/web2c}
> LuaTools | fileio: loading configuration file /usr/local/context/ 
> 2009-06-11-beta/texmf/web2c/texmfcnf.lua
> .....
>
> Then I tried a simple test file after using "luatool --generate" on  
> my non-admin account:
> titus:wech jh$ luatool --generate
> titus:wech jh$ context myriad.tex
> ...
> ...
> /2009-06-11-beta/texmf-context/tex/context/base/type-otf.mkiv)))
> system          : myriad.top loaded
> (myriad.top)
> fonts           : preloading latin modern fonts
> bodyfont        : 12pt rm is loaded
> language        : language en is active
> system          : module simplefonts loaded
> (/usr/local/context/2009-06-11-beta/texmf-local/tex/context/third/ 
> simplefonts/t-simplefonts.tex
> loading         : ConTeXt User Module / Simplefonts
> ! Undefined control sequence.
> l.707 \startprocesscommacommand
>                             [\simplefonts!weight]
> ?
> ---Terminal Output---
>
>
> Well, it seems that your instructions did basically work, since the  
> module simplefonts is loaded. But nevertheless the simple test file  
> aborts and complains about " Undefined control sequence. l.707  
> \startprocesscommacommand[\simplefonts!weight]".
>
> Do you have an idea what went wrong on my side?

Yes. Although the module is found it crashes during initialization.  
Observe that

---
\usemodule[simplefonts]


\starttext

This tests whether the module \type{t-simplefonts} is loaded  
successfully.

\stoptext
---

already hangs. The reason is that the latest version of the t- 
simplefonts module (which is the one you obtained) makes use of  
ConTeXt kernel commands (\startprocesscommacommand) which seem to have  
only been introduced lately. In other words, the version I packaged  
into the experimental installer is too old for the current module. So  
not your fault.

Keep in mind though that this might happen frequently without warning  
since you're working with development code here. For the moment I'm  
merely trying to establish something along the lines of a nightly  
installer build ... since there's no regression test suite I can't  
even test whether anything works but the most basic features. Also,  
modules don't check for a minimum kernel version required :-(

Best,
Oliver


More information about the dev-context mailing list