[dev-context] particular mpost label fails with recent ConTeXt

Hans Hagen pragma at wxs.nl
Fri Jun 12 10:21:55 CEST 2009


Taco Hoekwater wrote:
> Sanjoy Mahajan wrote:
>> The error in mpxerr.log is:
>>
>>   ! Illegal unit of measure (pt inserted).
>>   <to be read again>              =
>>   <argument> =
>>           \joinrel =\joinrel \Longrightarrow   \buildrel ...mathrel 
>> {\mathop {\kern \zerocount #2
>>                             }\limits ^{#1}}
>>   l.14     {=\joinrel=\joinrel\Longrightarrow}
>>                           $%
> 
> The problem is that the \zerocount that is used in buildrel:
> 
> \def\buildrel#1\over#2%
>   {\mathrel{\mathop{\kern\zerocount#2}\limits^{#1}}}
> 
> 
> somehow ends up being a \chardef. A shorter test file is:
> 
>   \starttext
>   $\buildrel a \over b $
>   \stoptext
> 
> the weird thing is that I can't figure out where that definition
> takes place ?? (well, there is one in syst-ini, but that should
> have been overwritten by the one in syst-gen, afaik).

math-ini.mkii

\def\buildrel#1\over#2%
   {\mathrel{\mathop{\kern\zeropoint#2}\limits^{#1}}}

-- 

-----------------------------------------------------------------
                                           Hans Hagen | PRAGMA ADE
               Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
      tel: 038 477 53 69 | fax: 038 477 53 74 | www.pragma-ade.com
                                              | www.pragma-pod.nl
-----------------------------------------------------------------


More information about the dev-context mailing list