[dev-context] error: You can't use `\vadjust' in internal vertical mode

Sanjoy Mahajan sanjoy at MIT.EDU
Fri Jun 5 15:57:18 CEST 2009

I've been running across the following error once a week or so:

  [MP to PDF] (./fig.320)
  floatblocks     : 16 placed
  ! You can't use `\vadjust' in internal vertical mode.
  <recently read> \vadjust 

  \sidefloatoutput ... \parskip \zeropoint \vadjust 
						    {\penalty \minusone }\iffl.
  <argument> ...\fi \else \the \defaultstreamoutput 
  \firstoftwoarguments #1#2->#1

  \dodonormaloutput ...lty \the \OTRcommand \output 
						    \outputmessage -{normal}\o.

  \invokeoutputroutine ...enalty }\dodonormaloutput 
						    \outputmessage -{trying}\o.


  This is MetaPost, Version 0.993 (Web2C 7.5.6)
  (lumping-mpgraph.mp [1]
  metafun 2009-5-5 07:22

It is very sensitive to the vertical spacing, and goes away when I
edit even slightly, but I've made the most minimal example that I can.
It is attached as a zip file whose contents are:

M Filemode      Length  Date         Time      File
- ----------  --------  -----------  --------  -----------
  -rw-r--r--       745   5-Jun-2009  09:09:20  fig.2
  -rw-r--r--      1162   5-Jun-2009  09:09:20  fig.202
  -rw-r--r--      3552   5-Jun-2009  09:09:20  fig.301
  -rw-r--r--      2807   5-Jun-2009  09:09:20  fig.302
  -rw-r--r--      3820   5-Jun-2009  09:09:20  fig.306
  -rw-r--r--      5748   5-Jun-2009  09:09:20  fig.307
  -rw-r--r--      2915   5-Jun-2009  09:09:20  fig.308
  -rw-r--r--     48157   5-Jun-2009  09:09:20  fig.310
  -rw-r--r--      8219   5-Jun-2009  09:09:20  fig.311
  -rw-r--r--      2683   5-Jun-2009  09:09:20  fig.320
  -rw-r--r--      3827   5-Jun-2009  09:09:20  fig.350
  -rw-r--r--      3291   5-Jun-2009  09:09:20  fig.351
  -rw-r--r--      1853   5-Jun-2009  09:09:20  fig.618
  -rw-r--r--      2054   5-Jun-2009  09:09:20  fig.619
  -rw-r--r--      2076   5-Jun-2009  09:09:20  fig.621
  -rw-r--r--      1720   5-Jun-2009  09:09:20  fig.623
  -rw-r--r--     42313   5-Jun-2009  09:44:10  lumping.tex
- ----------  --------  -----------  --------  -----------
                136942                         17 files

Run 'texexec lumping.tex' to see the problem.

I'm using context 2009.5.5 from the Debian unstable package.

I tried running lumping.tex on the live context, but could not reproduce
the problem.  I think that is because the figure files are not included
in the live run, and their absence changes the vertical spacing enough
to hide the problem.

I also tried downloading and running it through the latest minimals, but
the minimals failed trying to load the palatino fonts, and I haven't yet
figured out if that problem is with my setup or with the minimals.


`Until lions have their historians, tales of the hunt shall always
 glorify the hunters.'  --African Proverb

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/zip
Size: 58567 bytes
Desc: vadjust.zip
URL: <http://www.ntg.nl/mailman/private/dev-context/attachments/20090605/fe711f12/attachment-0001.zip>

More information about the dev-context mailing list