[dev-context] Bug#447559: chemtex is broken again

Soeren Sonnenburg bugreports at nn7.de
Wed Nov 14 20:01:08 CET 2007

On Mon, 2007-10-22 at 16:18 +0200, Hans Hagen wrote:
> Norbert Preining wrote:
> > forwarded 447559 dev-context at ntg.nl
> > thanks
> > 
> > Hi Hans, hi all!
> > 
> > We got the following bug report for the Debian package, but I guess that
> > should be fixed upstream:
> for latex, ppchtex is loaded via ppchtex.noc which says ...
> \let\normalunexpanded\unexpanded
> \input supp-mis.tex  \let\writestatus\undefined
> \input syst-gen.tex
> \input syst-fnt.tex
> \let\unexpanded\normalunexpanded
> (\unexpanded is an etex primitive but context had an \unexpanded before 
> etex came around; same for \protected as primitive; so here we push and 
> pop the meanings)
> so, i wonder if this user loads ppchtex in the right way
> (maybe i should make a derived version for latex usage - given that 
> there are users - in which case i can also cleanup and optimize the 
> context variant, but it has low priotity)

OK I got like two reports from different users who exactly had the same

One fixed it by simply inputting everythin in the .tex file:

\input supp-mis.tex 
\input syst-gen.tex
\input syst-fnt.tex
\input m-pictex.tex
\input m-ch-en.tex

the other removed the lines


from ppchtex.nox .

Then it worked for both.

So whatever you do please fix it as it is a bug that does not only annoy
me or alternatively tell us please how to correctly use m-ch-en ...



More information about the dev-context mailing list