[dev-context] where is dvipos? dvipos fails using TL2006 test tree

Sanjoy Mahajan sanjoy at mrao.cam.ac.uk
Sun Jan 7 01:49:32 CET 2007


> $ env KPATHSEA_DEBUG=-1 dvipos notes.dvi

Thanks; you can teach an old dog new tricks (which now I see is
documented in the kpathsea manual).  With sh/bash you can drop the
'env':

  $ KPATHSEA_DEBUG=-1 dvipos notes.dvi

The debug output helped me figure out the problem: $SELFAUTOPARENT
yukness.  dvipos is in /usr/local/bin/dvipos, so SELFAUTOPARENT is
/usr, and everything is being searched for in /usr/texmf,
/usr/texmf-dist, etc, instead of in $tlroot/texmf{,-dist} etc.

For binaries in TL, it all works since they live in
$tlroot/bin/i386-linux/, so their $SELFAUTOPARENT is $tlroot/.

I checked this analysis by putting a copy of dvipos in /tmp/x/y/ and
symlinking /tmp/texmf* to $tlroot/texmf*.  Then I ran /tmp/x/y/dvipos
notes.dvi (using TL's texmf.cnf), and it worked identically to using
dvipos with my regular tex installation (Debian/Ubuntu texlive).

So dvipos belongs in TL and in the Debian packages, or else ConTeXt
will crash when it makes dvi files with figures.

Also, as I mentioned in another email (I think to ntg-context),
ConTeXt needs to parse dvipos's scaled-points output.  But that change
is not specific to TL.  Or dvipos should be changed to produce
coordinates in pt (and label them).  However, that change may break
other users (are there any?) of dvipos.

-Sanjoy

`Not all those who wander are lost.' (J.R.R. Tolkien)


More information about the dev-context mailing list