[dev-context] bib entries missing full stops in "unpublished" and "book" types

Sanjoy Mahajan sanjoy at mrao.cam.ac.uk
Thu Dec 7 00:01:40 CET 2006

In the PDF output from this file (and bib file below), the full stop
(a.k.a. period) is missing after "editors" ad the title in the first
entry, and after the author ("...Foundation") in the second entry.

====================== proposal.tex ======================

Try \cite{HPL:2000}  and \cite{GPLv3}.


=====================  proposal.bib ======================
  author = 	 {Free Software Foundation},
  title = 	 {{\sc gnu} {G}eneral {P}ublic {L}icense revision},
  month =	 {November},
  year =	 2006

  editor =	 {John D. Barnsford and Ann L. Brown and Rodney R. Cocking},
  title = 	 {How people learn: Brain, mind, experience, and school},
  publisher = 	 {National Academy Press},
  year = 	 2000,
  address =	 {Washington, DC},
  edition =	 {expanded},
=====================  end proposal.bib ======================

It works fine in latex with the same proposal.bib, using this latex file:

====================== tlatex.tex ===================
Try \cite{HPL:2000}  and \cite{GPLv3}.


I tried comparing the {book} and {unpublished} code in cont-no.bst and
plain.bst (latex) but didn't have much luck figuring out why the full
stops are missing.  I've never noticed it with regular books (with just
authors), only with editors.  And I hadn't tried an unpublished entry
before with ConTeXt.

context version: 2006.11.22 11:02 / Ubuntu Linux / i386
BibTeX 0.99c (Web2C 7.5.4)

p.s. Should this mail go to dev-context or to the main list?


`Our society is run by insane people for insane objectives.' (John Lennon)

More information about the dev-context mailing list