Thanks, I reinstalled a later version of Textadept. I notice that it now opens the pdf product but in Xreader, the default on my machine, and that's no real problem, but now that I have got it working I can experiment a bit. Interesting, though, that the changes I made at your suggestion in l-pdfview.lua are not effective (I would have expected it to be okular). But I guess there is no harm done.


On 27/9/21 1:41 pm, Jairo A. del Rio wrote:

El dom, 26 de sep. de 2021 a la(s) 22:29, jbf ( escribió:

Hmm. I'm not using evince (could, I suppose) but I see that in the file you mention there is already:

['okular']    = [[okular --unique "%filename%"]], and I have already adapted the init.lua file in /.texadept to use okular rather than sumatra, with = '/home/me/bin/context/tex/texmf-linux-64/bin/mtxrun --autogenerate --script context --autopdf=okular "%f"'

So, following your logic, I should then only need to add, further on, pdfview.method = "okular", which I have done, but still no joy.

In such a case, you only need to comment on the second option, i. e. Sumatra:
    --The last one wins
    pdfview.method = "okular"
    --pdfview.method = "sumatra" -- faster and more complete

I haven't edited textadept settings btw, so it works for me with --autopdf alone.


On 27/9/21 1:06 pm, Jairo A. del Rio wrote:
Hi. Maybe there's an easier way to do it without changing any file or via mtxrun's command line, but the following is what I do:

In l-pdfview.lua (mkiv folder, lines from 38) PDF view options are available. I've added

['evince']    = [[evince "%filename%"]] -- My favorite viewer

And then, after pdfview.method assignments,

pdfview.method = "evince"

Now textadept opens the .tex file once compiled. I don't know if making the format again is mandatory, but it doesn't hurt, anyways. I hope this helps.
Best regards,


El dom, 26 de sep. de 2021 a la(s) 20:54, jbf via ntg-context ( escribió:
The occasional response to a similar question can be found, e.g. on
stackexchange, but none of the responses work for me.

Textadept is very fast at compiling (and does compile correctly). I can
certainly open the pdf independently in various pdf viewers, but I
cannot get Textadept to automatically open, say, Okular (installed on
Linux Mint), at the end of the process.

The last part of the log reads:

mkiv lua stats  > runtime: 0.640 seconds, 8 processed pages, 8 shipped
pages, 12.492 pages/second
mtx-context     | pdfview methods: auto default okular pdfxcview
sumatra, current method: okular (directives_pdfview_method)
pdfview         | command: okular --unique "test1.pdf" 1>/dev/null
2>/dev/null &
mtx-context     | pdfview overhead: 0.001 seconds
system          | total runtime: 0.649 seconds of 0.701 seconds

 > exit status: 0

Have tried setting up a custom text editor on okular with:
/home/me/.textadept "%f" -e textadept.editing.goto_line(%l-1), as
suggested by one response, but to no avail. Current version of ConTeXt
is 2021.09.17 10:01

Anyone tried Textadept successfully and might have a suggestion?


If your question is of interest to others as well, please add an entry to the Wiki!

maillist : /
webpage  : /
archive  :
wiki     :