I am trying to compile the example provided by khaled hosny https://github.com/khaledhosny/xits-math/blob/master/test-suite/arabic.tex.

However this is what I get

fonts           > virtual math > unable to resolve name mapsfromchar
fonts           > fallback modern rm 12pt is loaded
system          > begin file arabic.tex at line 5
Missing character: There is no ف (U+0641) in font lmroman12-regular!

I have the latest version of livtex.
When I run mtxrun --script fonts --list --all --pattern=xits

xits   xitsbolditalic   xits-bolditalic.otf

which is strange because the font xits-math is not listed

I have noticed that xits is already installed with livtext, and I have followed the instruction in this page to 'http://wiki.contextgarden.net/Fonts_in_LuaTeX' install the fonts in and I have also installed the fonts in the home_directory/ .fonts

I was able to use the xits math with lualatex and it worked fine.
luaotfload | load font: font family='xitsmath', subfamily='regular' found: xits-math.otf

Thanks in advance