Hi Charles

Firstly. I can take no credit for getting Context running on the new M1 Mac OS ARM. Hans and his team are the real heroes here. I just downloaded the zip file and off I went.

I don't normally use TexShop, I use Texworks, but I have it set up on my machine. I cant remember how I setup the engine but I checked it out and it runs as expected. Here is the engine I use:



export PATH=/Users/pothole/data/contextarm64/tex/texmf-osx-64/bin:/Users/pothole/data/context/tex/texmf-osx-64/bin

/Users/pothole/data/contextarm64/tex/texmf-osx-64/bin/mtxrun --autogenerate --script context --autopdf "$1"


I did exactly as you did only I unzipped into /data/contextarm64. I did this because I have another directory into which I unzipped the intel version. It means I have two ConText options, intel and arm. The only other differences are my engine is a bash file and I don't remember making it executable.

Hope this helps. I'm happy to help off list if you want.

Best Wishes


On 23/04/2021 12:11, Charles Doherty wrote:
Hi all (especially Keith who successfully got Context running on the new M1 Mac OS ARM)

Again thanks to Mojca for providing the Mac OS ARM download. I recently replace my old Mac with the new ARM one. 

I am having difficulty getting ConTeXt to work.  This is what I have done and the information from the console.

I downloaded:


In terminal:  cd /Users/charlesdoherty/context-osx-arm64

Ran sh install.sh

and all seems ok (following Keith’s advice on privacy).

I made an engine for TeXShop based on what worked before:

export PATH=$PATH:~/context-osx-arm64/bin:~/context-osx-arm64/tex/texmf-osx-64/bin
~/context-osx-arm64/tex/texmf-osx-64/bin/mtxrun --autogenerate --script context --directives="system.showerror" --autopdf "$1" --purgeall

I made it executable.

When I typeset a file in TeXShop using this engine I get:

/Users/charlesdoherty/Library/TeXShop/Engines/ARM.engine:3: bad CPU type in executable: /Users/charlesdoherty/context-osx-arm64/tex/texmf-osx-64/bin/mtxrun

I have tried various options to no avail but I would really appreciate some help on this (longhand rather than cryptic would be really helpful).


On 11 Apr 2021, at 19:27, Keith McKay <mckaymeister@gmail.com> wrote:

An alternative way is to go to Preferences>>Security and Privacy>>General. And then click on Open anyway and that's it sorted.
Best Wishes

On Sun, 11 Apr 2021, 18:47 Otared Kavian, <otared@gmail.com> wrote:

Thank you Mojca and Hans for the new binary for MacOS ARM: yesterday I installed it on my new MacBook Pro ARM and everything works like a charm.

Just for the persons who run into difficulties when running
        sh install.sh
and see that MacOS 11 prevents mtxrun to run properly, in the Finder you should find the file


and then you press Control while clicking on it. You’ll see a pop up window, and you choose Open, and when the Finder tells you whether you really want to open that file, you say YES…
After this, the install script does what it has to do and you don’t need anymore to authorize mtxrun to run.

Best regards: Otared

D24 YH2V
home: +353 1 2447483
Mobile: +353 863868629

If your question is of interest to others as well, please add an entry to the Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki     : http://contextgarden.net