recently I've installed ConTeXt and after all the complicated configurations I could finally write my first chinese text, but as I tried MetaFun today, I got very strange error message: I tried to compile the trivial sample on the first page of "metafun-p.pdf":
fill fullcircle scaled 5cm withcolor red ;
I invoked "texexec test", after some messages scrolled by it stopped and show:
!Equation cannot be performed (numeric=boolean)
I traced to that line in the file "test-mpgraph.mp" which has been produced by texexec in the first step and I simply deleted it, then I ran "mpost test-mpgraph" manually and got "test-mpgraph.1" without any problem, but as I viewed it with GSview there was only a quarter of disc, which should be a 5cm filled circle. I've also tried with other Metapost files but got always the same result: that line will always be added to the intermedia file. I think it's not because of a wrong configuration of ConTeXt but something "deep inside".
btw. I'm using MikTeX 2.2, ActivePerl 5.8, ConTeXt is the newest version while TeXExec somehow old (v3.1), but I don't think the problem lies there because exept metapost the other part works well, for the configuration of MetaFun I've done following:
I first edited the corresponding part of /texmf/context/config/texexec.ini to be suited to MikTeX, then after refreshing MikTeX name database I did a "texexec --make --alone metafun", it produced metafun.mem in /localtexmf/miktex/fmt, I moved it then to /localtexmf/miktex/mem
now I absolutely have no idea about it... I would be very thankful if someone can tell how to fix around, besides I do want to know what's wrong.
Best regards,