Hi Pablo,

First of all, my bad, the test suite example works just fine in Adobe, including with ConTeXt latest.

I have messed up my form by overriding the PDF version to 2.0, shouldn't have done that.

On the viewers, I cannot recall exactly what I've done earlier in the year, but indeed, most likely I have tried evince after signing it from the command line. From https://gitlab.gnome.org/GNOME/evince/-/issues/143 there is still no support for the signing itself, though okular should have some support.

In any case, thanks for the hints (I probably should've done more testing)!


On Sun, May 2, 2021 at 5:50 PM Pablo Rodriguez <oinos@gmx.es> wrote:
On 5/2/21 12:20 AM, Adam Reviczky wrote:
> Hi,
> I cannot get the signature working either, but almost certain it did
> work in February this year, as I have done some with MKIV.
> [...]

Hi Adam,

I’m on a Linux computer, so I’m not able to check this now.

If the signature isn’t working, you mean that the output PDF document
from fields-007.tex cannot be signed with Acrobat DC, don’t you?

Sorry for asking the obvious question, but this worked perfectly fine
each time I tested.

> Using the https://live.contextgarden.net/ with (LuaTeX 2.06 20200630 +
> ConTeXt MkIV 2020.06.30 17:30) looks good, but evince does not display
> the field.

Evince never displays the signature field, only when signed.

BTW, using mupdf-gl to sign the PDF document will mess it, since it has
problems to recognize the child object.

>From my experience, only Acrobat deals with child objects in signatures
generating a valid signature (and rewriting the two objects into a
single one).

Just in case it might help,

If your question is of interest to others as well, please add an entry to the Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki     : http://contextgarden.net