On Fri, Apr 13, 2018 at 10:48 AM, luigi scarso <luigi.scarso@gmail.com> wrote:

On Fri, Apr 13, 2018 at 10:16 AM, Rodzis, Michelle <rodzis@sub.uni-goettingen.de> wrote:

Dear list,

currently I work on a customized Docker container based on Ubuntu 16.04 where I run ConTeXt standalone. To install ConTeXt, I use the approach described in the wiki:

RUN wget http://minimals.contextgarden.net/setup/first-setup.sh &&\
    sh ./first-setup.sh --modules=all

After setting ConTeXt root everything works fine and as expected. However, the texfont tool seems to be missing which means I cannot install new fonts in my container. This seems kind of odd to me since I thought texfont is available automatically after ConTeXt is installed.

I also tried Henri's Debian-based Dockerfile, but texfont seems to be missing there, too.

Any ideas on this? Have I missed something?

Many thanks in advance and best wishes,

Are you using (or do you want to use)  context mkii ?

texfont is still shipped
as  you can see in 

and you can run it with
$ mtxrun --script texfont  --help

Do, for r mkii you need to provide in some way pdftex, perl and ruby
(for the scripts under tex/texmf-context/scripts/context/ruby)