Meer, Hans van der
11. Oktober 2016 um 14:43
A problem I am obviously not able to solve.
It can be described as follows.

I have an xmlsetup <tex>..</tex> that typesets texcode embedded in an xml document. Now it is needed to embed initializing a buffer and typesetting lateron with \getbuffer. Alas, doing the following does not woek:
because the TeX input hangs. My guess being that the \stopbuffer fails to terminate the data intake.

I then tried to split off the buffer filling with a separate xmlsetup. But here too, the TeX input halts:

% Usage: <buffer name="name">
\startxmlsetups xmlcommon:buffer
% Usage: <getbuffer name="name">
\startxmlsetups xmlcommon:getbuffer

and as input: <buffer name="name">inputdata</buffer> followed by .
The getbuffer setup is not even reached, as is obvious.

I tried \xmltofile to put the data into an intermediate file, but to no avail because it produces the following, leading at best to recursion when processed by \xmlprocessfile.

<?xml version="1.0" ?>
<!-- exported fragment -->

Is there a solution to this?