[NTG-context] Problems installing Gentium TTF

Henning Hraban Ramm hraban at fiee.net
Sun Jan 22 14:03:42 CET 2006

Am 2006-01-22 um 12:25 schrieb Kumar Appaiah:

>> I don't know where your problems come from.
>> You could just try using the package from my site:
>> http://www.fiee.net/texnique/?menu=0-1-4
>> Don't forget to texhash!
> Thanks.	I did the same, and I still have a similar problem. I
> installed the font in /usr/local/share/texmf, and ran texhash. Now,
> that ls-r has the font info. I am getting the following:
> (Part of the output):
> kpathsea: Running mktexmf ec-genr101
> ! I can't find file `ec-genr101'.
> <*> ...four; mag:=1; nonstopmode; input ec-genr101
> Please type another input file name
> ! Emergency stop.
> <*> ...four; mag:=1; nonstopmode; input ec-genr101
> [snip]
> l.6 \setupbodyfont      [sil-gentium, rm, 12pt]
> ? H
> I wasn't able to read the size data for this font,
> so I will ignore the font specification.
> [Wizards can fix TFM files using TFtoPL/PLtoTF.]
> You might try inserting a different font spec;
> e.g., type `I\font<same font id>=<substitute font name>'.
> Could you give me any further suggestions?

Did you read the thread "font encodings (glyph lossed..."?
As you see, we have some problems with TrueType fonts.
My font package from this morning is better than the old one, but  
still lacks at least the 'dcroat' letter.

But your problem is another kind.
I'd suggest to start over and use the latest Gentium distribution  
(1.02), but so far:

What Gentium files do you have in your fonts tree? Which vendor/ 
collection names did you use? (sil/gentium?)
- AFMs (not needed)
- TTFs (texmf/fonts/truetype/sil/gentium/*.ttf)
- TFMs (texmf/fonts/tfm/sil/gentium/*.tfm)
- MAPs (texmf/fonts/map/pdftex/context/ec-sil-gentium.map)

Did you rename all files to lowercase (and without spaces)? ConTeXt  
sometimes has problems if file names use uppercase letters.

There should be ec-genr101.tfm and .ttf in your case, that's what TeX  
is looking for.

If the TFM is found, you'll run in the next problem: Probably in  
the .map file there's '.pfb' instead of '.ttf'

I always need to run texhash with root permissions ('sudo texhash'),  
otherwise the database cannot be written.

Greetlings from Lake Constance!
http://www.cacert.org (I'm an assurer)

More information about the ntg-context mailing list